Reproductor MP3 y auriculares

* *


Hilo del reproductor XDUOO X2

0 Usuarios y 2 Visitantes están viendo este tema.

Re:Hilo del reproductor XDUOO X2
« Respuesta #165 en: 12 de Junio de 2016, 01:08:14 pm »
Hola,
Tengo problemas con las tarjetas de 64Gb y es que en algunos discos me da error de archivo, se escucha la canción 2 segundos y me salta el error.
Ese mismo disco en una tarjeta de menor capacidad me lo reproduce sin problema y esas tarjetas de 64Gb en un Fiio funciona sin problema por lo que descarto que sea tanto del archivo como de la tarjeta ¿alguien puede decirme algo al respecto?

He formateado la tarjeta en Fat32 por si fueran por ahí los tiros pero sigo igual...

Muchas gracias y saludos.

Hola, dinos con qué programa formateas la memoria de 64 gigas y también marca y modelo de la memoria... para que vayas probando, te recomiendo que formatees con un programita específico para formatear tarjetas sd y microsd de tantos que hay en internet y no usar el comando de windows y mucho menos usar formateos rápidos (no lo recomiendo nunca ni para memorias flash ni para discos duros magnéticos)... además, una vez consigas formatearla correctamente con uno de esos programas, te recomiendo una aplicación para ordenar los archivos en la tarjeta ya que por defecto el xduoo te los ordena por fecha de creación si no recuerdo mal... a continuación te pongo un par de ellos para que pruebes pero te recomiendo que chequees si son de confianza los lugares para descargar ya que no los he comprobado, nunca los compruebo porque tengo firewall y antivirus totalmente actualizados y 100% funcionando:

hp-usb-disk-storage-format-tool.softonic.com
http://www.techspot.com/downloads/6582-hp-usb-disk-storage-format-tool.html
http://recordandoamagonico.blogspot.com.es/2010/05/hp-usb-disk-storage-format-tool-v218.html

http://www.techsupportalert.com/content/sort-files-alphabetically-usb-stick-or-mp3-player.htm
http://es.freedownloadmanager.org/Windows-PC/FAT-Sorter-GRATIS.html
http://fat-sorter.software.informer.com/Descargar-gratis/

Un saludo.

Desconectado Elnota

  • ***
  • 123
    • Ver Perfil
Re:Hilo del reproductor XDUOO X2
« Respuesta #166 en: 12 de Junio de 2016, 06:47:17 pm »
Gracias albejanon,

Te comento, la tarjeta es una kingston pero la he probado también en una marca asiática llamada Mixza con igual resultado.

Como bien dices los tiros debían de ir por el formateo de la misma, yo uso OSX y al final la he formateado por el terminal y no por la aplicación de disco que trae el propio sistema operativo y parece ser que ha quedado resuelto el problema.

Por si le sirve a alguien ge seguido la siguiente guía: http://michaelcrump.net/the-magical-command-to-get-sdcard-formatted-for-fat32/

Gracias y saludos.

Re:Hilo del reproductor XDUOO X2
« Respuesta #167 en: 22 de Julio de 2016, 12:48:44 pm »
Hola!! Me llego el otro día y estoy encantado pero al encender o apagar escucho un ruido metálico "click". Me figuro que tiene que ser el corte de energía o al revés. Alguien sabe el motivo o si por contra es normal en este tipo de dispositivos. Tengo un ipod classic, zip, reddmango, fuze+ y ninguno lo hace. 

Desconectado Jaxxon

  • *****
  • 2518
    • Ver Perfil
    • Email
Re:Hilo del reproductor XDUOO X2
« Respuesta #168 en: 23 de Julio de 2016, 09:28:03 am »
El mio también lo hace, me imagino que será algún interruptor, a saber, me preocuparía cuando no lo hiciera

Desconectado markkkun

  • ***
  • 185
  • Orejas de trapo
    • Ver Perfil
Re:Hilo del reproductor XDUOO X2
« Respuesta #169 en: 23 de Julio de 2016, 11:10:21 am »
Yo lo estuve investigando a raiz de que que el Fiio X3 1gen también hacía los mismos ruidos.

Por lo que pude leer es un mecanismo de seguridad mediante un relé (creo que era) para deshabilitar la salida de sonido o algo así cuando se enciende el chip amplificador, debido a que durante el proceso puede emitir sonidos que supongo te pueden dejar sordo  :silbar:

Pego el extracto de info que encontré de fiio:

Citar
Q: Why does the X5 2nd gen/X3 2nd gen/X3/X5 make a clicking sound when turning on / off and when headphones are inserted / removed?
A: The X5 2nd gen/X3 2nd gen/X3/X5's headphone output goes through a relay to the headphone output. The relay disengages briefly when the X5 2nd gen/X3 2nd gen/X3/X5 is turning on and off and when headphones are connected / disconnected from the X5 2nd gen/X3 2nd gen/X3/X5, thus isolating headphones from potentially dangerous transient pops when the amplifier section is powered on and off. The relay is a mechanical connection that makes a small clicking sound when engaging / disengaging

Entiendo que el X2 tiene un sistema parecido.
Orejeros: AKG K551, Takstar HD5800
Portables: Beyerdynamic DTX350M, Koss Porta Pro & KSC75
IEM: Dunu DN-2002, VSONIC GR07
Botón: Shozy Cygnus, VE Monk
Reproductores:  Meizu Pro 5.
DAC: Zuperdac
Amp.: Headstage Arrow 4T

Re:Hilo del reproductor XDUOO X2
« Respuesta #170 en: 23 de Julio de 2016, 04:28:13 pm »

Entiendo que el X2 tiene un sistema parecido.
[/quote]
El mio también lo hace, me imagino que será algún interruptor, a saber, me preocuparía cuando no lo hiciera

Yo lo estuve investigando a raiz de que que el Fiio X3 1gen también hacía los mismos ruidos.

Por lo que pude leer es un mecanismo de seguridad mediante un relé (creo que era) para deshabilitar la salida de sonido o algo así cuando se enciende el chip amplificador, debido a que durante el proceso puede emitir sonidos que supongo te pueden dejar sordo  :silbar:

Pego el extracto de info que encontré de fiio:

Citar
Q: Why does the X5 2nd gen/X3 2nd gen/X3/X5 make a clicking sound when turning on / off and when headphones are inserted / removed?
A: The X5 2nd gen/X3 2nd gen/X3/X5's headphone output goes through a relay to the headphone output. The relay disengages briefly when the X5 2nd gen/X3 2nd gen/X3/X5 is turning on and off and when headphones are connected / disconnected from the X5 2nd gen/X3 2nd gen/X3/X5, thus isolating headphones from potentially dangerous transient pops when the amplifier section is powered on and off. The relay is a mechanical connection that makes a small clicking sound when engaging / disengaging


Gracias chicos, me quedo mucho más tranquilo  :mrgreen:

Re:Hilo del reproductor XDUOO X2
« Respuesta #171 en: 10 de Agosto de 2016, 08:12:01 pm »
Hola, me presento: Soy Jose Sabino (albejanon en este foro y otros) y os agradezco la información que me habéis dado antes de registrarme... mi intención no es otra que la de devolveros el favor aportando mi granito de arena para que aquel que se haya llevado un susto con su Xduoo X2, lo pueda traer de vuelta desde ese lugar lúgubre que es el limbo celestial...

Vamos, que para cuando se muere el bisho, aquí tenéis LA ÚNICA GUÍA PASO A PASO :gorra: para revivirlo que podréis encontrar en internet, realizada por mí :pretty: y que espero os sea de gran ayuda como a mi me ha sido (mejor no tener que hacer uso de ella)... el documento es de mi creación, en formato pdf, sin copyright ni historias (si es así, hacédmelo saber) y doy mi total permiso para que se modifique siempre que sea para mejorarlo, aportando más luz si cabe al despertar del cementerio de este reproductor: el Xduoo X2 que tantas horas de buena música y con gran calidad me ha dado y seguirá dando hasta que no pueda revivirlo. :big: :big: :big:

Un saludo y felices audiciones. :dios: :dios: :dios:

PD: No me hago responsable del mal uso de la guía... no ofrezco ningún tipo de garantías ni nada por el estilo... gratis encontré parte de la información y gratis la ofrezco ordenada, ampliada y procesada para evitar errores... su uso o no, es responsabilidad sólo de aquel que descargue la guía y la ponga en práctica... soy electrónico y mi única intención con ésto es sólamente ayudar. :dinero: :dinero: :dinero:

Estimado amigo:

Soy un usuario nuevo del foro. He llegado aquí buscando en internet, precisamente, la info que tú has colgado y por la que no puedo sustraerme a darte aquí y ahora mis más expresivas gracias ya que me ha pasado algo igual o similar a lo descrito en el pdf.

Tengo un Xduoo x2 comprado hace, aproximadamente, un año en Banggood Europa (Inglaterra) y después de un uso nada intensivo -unas diez horas- se ha muerto por completo.

Al encenderlo, presentó la pantalla habitual con el tema que sonaba la última vez que se usó, pero sin permitir ninguna operación. Se mantuvo así como unos 30 segundos y a continuación se murió.

Por supuesto, el reset no hace nada, excepto el típico sonido de "click". Nada más.

Tampoco carga ni parece que pueda ser conectado al usb del PC, aunque lo reconoce, pero sin llegar a mostrarlo en pantalla, por lo que creo que el fallo no es de hardware ni nada de eso, sino más bien de firmware o mejor dicho, de ausencia del mismo por causa de la pérdida de la memoria.

Como está en garantía aun, (xduoo da un año) y lo compré en Europa -aunque a través de tienda china- Tengo la tarjeta de garantía  -sin cubrir- del fabricante.


Está bastante claro que este modelo trae algún defecto de arquitectura ya que no encuentro nada normal que algo así -perder el firm- suceda con la relativa frecuencia que estoy leyendo...

En fin, a ver si soy capaz de encontrar alguna manera de arreglar el desaguisado porque lo cierto es que el cacharrito va muy bien -cuando funciona, claro-

En cualquier caso reitero, a tí en particular y a todos los participantes en este hilo -y este foro- en general mi agradecimiento por la desinteresada info que dais a la que espero poder corresponder en la medida de mis posibilidades.



Edito para comentar que no ha funcionado el sistema.

Sigue haciendo lo mismo que antes de resetear la memoria, que viene siendo que al conectarlo al pc por el usb, lo reconoce como "dispositivo no reconocido".

Al mirar en sistema, encuentro que asigna el nombre:

USB/VID_10D6&PID_10D6/5&17B29F89&0&4

Y la identificación del dispositivo es:

USB\VID_10D6&PID_10D6&REV_0100
USB\VID_10D6&PID_10D6


Tras investigar un poco por internet, el fabricante del driver que coincide con el Product ID y el Vendor ID del xduoo es Actions Semiconductor.

Es un driver relativamente antiguo y no muy fácil de encontrar -al menos para mi no lo ha sido-



El driver está en (http://www.driversguru.com/driverdownload/Actions%20USB%202.0%20(HS)%20WinUSB%20Device):
 
Y es el siguiente:

[Version]
Signature = "$Chicago$"
provider  = %manufacturer%
DriverVer = 7/24/2008,2.0.0.3

Class=USB
ClassGUID={36FC9E60-C465-11CF-8056-444553540000}

[Manufacturer]
%manufacturer%=Actions,NTx86,NTamd64

[Actions]
%USB\VID_10D6&PID_ff51.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff51
%USB\VID_10D6&PID_ff61.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff61
%USB\VID_10D6&PID_ff63.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff63
%USB\VID_10D6&PID_ff66.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff66
%USB\VID_10D6&PID_ff79.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff79
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff88
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff76
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff96
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_fe01
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_fe02
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10D6&PID_fd01
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10D6&PID_10D6

[Actions.NTx86]
%USB\VID_10D6&PID_ff51.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff51
%USB\VID_10D6&PID_ff61.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff61
%USB\VID_10D6&PID_ff63.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff63
%USB\VID_10D6&PID_ff66.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff66
%USB\VID_10D6&PID_ff79.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff79
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff88
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff76
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff96
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_fe01
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_fe02
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10D6&PID_fd01
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10D6&PID_10D6

[Actions.NTamd64]
%USB\VID_10D6&PID_ff51.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff51
%USB\VID_10D6&PID_ff61.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff61
%USB\VID_10D6&PID_ff63.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff63
%USB\VID_10D6&PID_ff66.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff66
%USB\VID_10D6&PID_ff79.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff79
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff88
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff76
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_ff96
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_fe01
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10d6&PID_fe02
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10D6&PID_fd01 
%USB\VID_10D6&PID_ff88.DeviceDesc%=WINUSB_DEV, USB\VID_10D6&PID_10D6

;-------------------------------------------
[WINUSB_DEV]
AddReg = winusb_add_reg_hw

[WINUSB_DEV.Services]
AddService = winusb, 0x00000002, winusb_add_service

-------------------------------------------
[WINUSB_DEV.NT]
AddReg = winusb_add_reg_hw
Include=WINUSB.INF ; Import sections from WINUSB.INF
Needs=WINUSB.NT ; Run the CopyFiles & AddReg directives

-------------------------------------------
[WINUSB_DEV.NT.HW]
AddReg = winusb_add_reg_hw
Include=WINUSB.INF ; Import sections from WINUSB.INF
Needs=WINUSB.NT ; Run the CopyFiles & AddReg directives
-------------------------------------------

[WINUSB_DEV.NT.Services]
AddService = winusb, 0x00000002, winusb_add_service
;fix bug
AddService = Wdf01000, 0x00000001, wdf01000_add_service

[wdf01000_add_service]
DisplayName    = "Wdf01000"
ServiceType    = 1
StartType      = 3
ErrorControl   = 1
ServiceBinary  = %12%\wdf01000.sys


;-------------------------------------------

[winusb_add_reg_hw]
; replace this with you own GUID !!!
HKR,,DeviceInterfaceGUIDs, 0x10000,"{FF7B846F-B0A3-45C0-B0FC-D8122086996D}"


[winusb_add_service]
DisplayName    = "WinUSB Driver"
ServiceType    = 1
StartType      = 3
ErrorControl   = 0
ServiceBinary  = %12%\winusb.sys

[SourceDisksNames]
1 = "Actions USB 2.0 (HS) WinUSB Device"

[Strings]
manufacturer = "Actions Semiconductor Co., LTD"
USB\VID_10D6&PID_ff51.DeviceDesc = "Actions USB 2.0 (HS) WinUSB Device"
USB\VID_10D6&PID_ff61.DeviceDesc = "Actions USB 2.0 (HS) WinUSB Device"
USB\VID_10D6&PID_ff63.DeviceDesc = "Actions USB 2.0 (HS) WinUSB Device"
USB\VID_10D6&PID_ff66.DeviceDesc = "Actions USB 2.0 (HS) WinUSB Device"
USB\VID_10D6&PID_ff79.DeviceDesc = "Actions USB 2.0 (HS) WinUSB Device"
USB\VID_10D6&PID_ff88.DeviceDesc = "Actions USB 2.0 (HS) WinUSB Device"

[WINUSB_DEV.NT.Wdf]
KmdfService = WINUSB, WINUSB_wdfsect
UmdfServiceOrder=UMDFSkeleton

[WINUSB_wdfsect]
KmdfLibraryVersion = 1.5


Tras instalar el driver de Actions Semiconductor (AdfuUpdate.inf), el pc ya reconoce al Xduoo, como un dispositivo USB (Actions USB 2.0 (HS) USB device)

Bien, esto quiere decir que el hardware del xduoo está bien y tal como me temía se ha producido -por motivos inexplicables- una corrupción total del firmware, pero al menos ahora se que tengo un pisapapeles funcional.

El problema surge con que el programa que proporciona xduoo para cargar el firmware nuevo sólo trabaja con protocolo TMP y no reconoce ningún dispositivo de estas características conectado.

Mis conocimientos de informática son los que son, así que toca seguir investigando. No se si lograré hacerlo revivir, pero al menos entretenido si que se me tiene.

Cualquier ayuda o referencia, insisto, sería muy bienvenida y creo que este post podrá ser de mucha ayuda en un futuro no muy lejano.

Saludos.

« última modificación: 12 de Agosto de 2016, 06:08:26 pm by Slimslide »

Re:Hilo del reproductor XDUOO X2
« Respuesta #172 en: 18 de Agosto de 2016, 11:51:23 am »

Re:Hilo del reproductor XDUOO X2
« Respuesta #173 en: 22 de Octubre de 2016, 10:32:50 pm »
Bueno, me he perdido unas cuantas cosas desde que no vengo por aquí por motivos de trabajo... en fin, a ver si os puedo echar una mano:

- El click que se oye, efectivamente es un micro-relé que conmuta al encender por motivos de seguridad y si no me equivoco, que puede ser, cuando se conecta el cargador... sin problemas por este particular y no es nada que indique una mala calidad del diseño... sí quizás un diseño económico pero nada más (esperemos que no se joda el relé nunca).

- Para contestar a Slimslide: es tontería preguntarlo pero supongo que has seguido paso a paso el manual que anexé en su momento... si no recuerdo mal, hay que tener a la mano una versión lo más antigua posible para cargar una vez detectado "er bisho"... acto seguido, y aunque el manual diga lo contrario, ir directamente a la herramienta de carga de firmware ya que la aplicación previa que realiza la selección y llamada a la que carga el firmware directamente puede no ir muy fina.

Cuéntanos tus experiencias con el reproductor a ver si sacamos entre todos algo en claro.

Un saludo.

EDITO:

PD1: en la imagen adjunta, el recuadro amarillo es el microrelé...

PD2: Slimslide, adjunto el datasheet del AK2117C por si te es de ayuda, concretamente el pinout del chip que está a partir de la página 125 inclusive y también el de la memoria flash. A mi corto entender el AK dispone de una memoria BROM con un mínimo de comandos que dan paso a la carga del firmware en la memoria flash (la memoria BROM o BPROM por lo visto sólo es programable una única vez, pero no me hagas mucho caso ya que me he leído muy de pasada el datasheet del AK y no estoy my seguro de cuantas memorias ROM y RAM dispone)...

También he visto una línea en el archivo inf que has adjuntado que literalmente pone:

[winusb_add_reg_hw]
; replace this with you own GUID !!!
HKR,,DeviceInterfaceGUIDs, 0x10000,"{FF7B846F-B0A3-45C0-B0FC-D8122086996D}"

lo negrito subrayado itálica lo he puesto yo... supongo que ya lo has hecho pero si no entiendo mal, aquí deberías poner los GUID o el GUID (Identificador Único Global) del Xduoo X2 o de lo contrario no funcionará correctamente el cargador de firmware ya que identificará inequivocamente el dispositivo con su GUID correspondiente... No lo he buscado porque no dispongo ahora de mucho tiempo pero puedes encontrar el GUID del XduooX2 por San Google.

Seguimos con ello.
« última modificación: 23 de Octubre de 2016, 07:49:03 pm by albejanon »

 


//
TinyPortal © 2005-2011